概述

Neat Image是一个设计用来为数字摄影图像减少可见噪波的数字滤波应用程序.

噪波是阻碍高质量数字图像处理的严重问题. 在数字摄影中, 消费者和销售者的摄像机产生的图像容易察觉噪波成分. 这种成分尤其在ISO标准的图像里更强烈. 减少数字图像噪波的可视等级并且打印出结果. 有的图像处理操作, 象sharpening(锐化), 甚至使有噪波的图像质量更坏.

Neat Image能检测, 分析和去除图像噪波. 因为Neat Image有专用特性的特殊图像采集装置, 所以过滤品质比其他方法更好, 而且过滤更精确. 程序能适应几乎任何系列输入工具(数字摄像机, 扫描仪, 等等.). 存取丰富的控制设置可以轻易完成希望减少的噪波级别.

除了过滤噪波之外, Neat Image可以使图像外观清晰. 这不会降低任何图像品质(有噪波的图像通常不可避免). 结合锐化和噪波过滤器制作出这样的效果是可能的.

见examples of Neat Image performance (Neat Image操作范例).

当前Neat Image有四个版本: 演示版, 普通版, 专业版和专业版+. 演示版是免费的版本软件, 只有轻微地 - 有限的功能. 普通版是Neat Image 的零售版本适用于普通用户. 专业版是Neat Image 的零售版本适用于专业用户. 专业版+包括了另外的噪波过滤器插件.


Requirements(要求)

推荐处理2-3-兆像素图像的系统配置是:

· Windows 9x, ME, NT, 2000, XP

· Pentium-II级别CPU或更高

· 64 MB内存或更高

· 分辨率为1024x768或更高的真彩显示

最小系统要求是:

· Windows 95

· Pentium-ICPU

· 32 MB内存

· 分辨率为800x600的真彩彩色显示

Neat Image实际应用时对系统的要求取决于来源图像的大小. 越多可用的系统内存可以处置较大图像. 处理速度主要取决于CPU型号 – 功率.

输入图像的格式可以是下面其中的一种(支持保存相同格式输出图像***):

· TIFF (未压缩的, 单一图像, 无层, 无alpha 通道)
- 24-bit RGB
- 48-bit RGB
- 8-bit灰度
- 16-bit灰度

· JPEG
- 24-bit RGB
- 8-bit灰度

· BMP (未压缩的, Win3x)
- 24-bit RGB
- 32-bit RGB

输入图像的最小尺寸为20x20像素; 最大尺寸通常由系统可用内存数量限制.

*** 存储TIFF和BMP格式的输出图像还有复制到剪贴板仅在Neat Image的通用版本和专业版本有效.


Neat Image的功能 — 它能做些什么

Neat Image是过滤数字图像的应用程序. 程序的主要功能是减少数字图像的噪波.

Neat Image能和许多成像设备一起工作 – 数字摄像机, 扫描器, 等等. 程序可以通过噪波观察面设备的方法单独调节设备, 包括数据描述噪波特性的设备. 观察面包括一个工作色彩空间(空间用来为噪波分析), 分析区域参数, 不同类型的噪波强度, 等等.

噪波观察面设备直接建造分析用的专用图像区域. 主要想法是在分析之后让用户选择和指定图像区域包括不可见的(或重要的)细节. 程序不能从重要的图像细节里辨认噪波(或一些不必要的细节, 象间歇干扰). 解决办法是用户来选择一个包括无重要细节的区域. 通过一次这样的分析, 程序在整个图像里对特殊噪波类型适应后再有效减少整个图像噪波.

为了更好的分辨率Neat Image 噪波过滤器处理图像在三个频率范围里. 如果现存细节在其它范围, 仅允许去除频率范围噪波.

Neat Image能使用不同的工作色彩空间(RGB, YCrCb JPEG或YCrCb Symmetric)来分析和过滤输入图像. 选择正确的工作色彩空间能很好的增加过滤效率. 例如, 色彩空间YcrCb能单独分离图像的白度和颜色(亮度和色度)成分, 因此它更易用来仅处理白度成分, 通常包括可见噪波较大部分.

通常噪波特性的强烈取决于图像区域的局部白度. Neat Image使用噪波观察面均衡器来测量这些特性, 并且将它放到过滤过程的评估里.

除了噪波过滤之外, Neat Image还有锐化过滤, 只锐化重要的图像细节不增加噪波级别. 这个过滤器使用与噪波过滤器相同的噪波观察面设备, 因此一起使用它们能节省时间并获得更好的总体结果.


处理的图像类型

Neat Image是设计用来减少通过数字摄像机和扫描仪产生的图像噪波, 并且还能用来处理从其它来源的图像. 不过, 输入图像需要满足下列条件:

噪波属性

· 噪波必须是均匀分布在整个图象, 例如, 在图像的有些区域这些可能是不强烈的噪波或整个图像明显变化的噪波特性.

Neat Image能处理如高ISO噪波的图像. 不过, 'hot' 或'dead'像素(由单一'坏'的图像灵敏元素产生)不适合均匀条件, 因此, 通过Neat Image 不能有效地去除(hot像素是我们研发的目标).

另一个常见的噪波来源是JPEG压缩. 当使用高品质压缩时, JPEG噪波大致均匀(低压缩比). 不过, 低品质压缩使噪波不 - 均匀. 因此, 每当有可能时我们推荐使用高品质压缩. 设法避免可见的人为现象(通过JPEG压缩引入的'方形'或'块')要在输入图像早期图像处理开时!

· 噪波应当集中在高和中的频率上. 这种图像的情况通常由现代数字摄像机产生. 如果使用强烈数字放缩特性(例如, x2-x3和更大)的数字摄像机, 这种情况不可能完全满足其条件.

图像采集设备

· 如果是使用噪波观察面均衡器, 那么图像主要传感器采集设备将是 RGB (与使用减去原色的图像传感器比较). 那要求不是严格的. 它可能要在Neat Image 的未来版本里得到完全解决.


Overview of filtration process

Overview of filtration process(过滤处理概述)

可以使用 filtration job editor(过滤工作编辑器)来过滤图像. 当创建一个新的过滤工作时会打开过滤工作编辑器(通过用户或自动). 当开始起动Neat Image时, 过滤工作编辑器是自动打开的.

使用过滤工作编辑器:

1) 打开 input image(输入图像)

- 浏览器将显示输入的图像;

- 在右侧的面板上显示图像有关数据;

2) 准备 device noise profile(噪波观测面设备) - 必要的过滤输入图像噪波分析

- 可以选择保存一个噪波观测面或新建一个这样的光亮迹;

- 选择图像一平常区域(要有噪波)并用 rough noise analyzer(粗略噪波分析器) 让Neat Image来分析;

- 可以另外使用 fine-tuning analyzer(精细调节分析器)在选择的其他平常区域精细的调节分析;

3) 调节 noise filter(噪波过滤器)和 sharpening settings(锐化设置)来完成要求的噪波降低和锐化级别

- 可以选择任何图像区域, Neat Image将过滤这个区域并能预览;

- 可以改变任何的过滤设置并立即观察预览结果;

- 只要预览结果是满意的, 下一步就可以开始过滤整个图像;

4) 应用过滤器

- 可以应用对整个图像的过滤;

- 可以通过output image(输出图像)和input image(输入图像)来评估比较所得的结果;

- 可以保存output image(输出图像)文件到磁盘上;


在Neat Image 里运行一个范例图像

我们对新的Neat Image用户准备了一个程序使用测试教材. 可以从Neat Image 网页上下载这个测试教材: test-kit for Neat Image software (250KB). 下载后请放到新的文件夹/目录里.

测试教材包含一个范例图像: SampleImage.jpg文件. 这个图像是取自典型的数字摄像机照片(本例是Nikon CoolPix 950). 关于测试图像的详细信息可以在 SampleImageInfo.txt 文件里得到.

请启动Neat Image并且跟随下面步骤看它能如何改善图像:

1. 打开范例图像
- 在 Input image(输入图像)里: 从工具栏上点击
- 在 Open input image file(打开输入文件)对话框中, 找到范例图像的文件夹/目录位置并双击 SampleImage.jpg 这个文件;

Neat Image将打开范例图像.

将注意到图像有强烈噪波, 特别在天空区域(使用卷动缩放工具来观看它). 这是由数字摄像机产生的典型噪波. Neat Image的任务是消除这些噪波. 要进行操作程序通常需要一些有关噪波的信息. 我们提前准备好了这些信息并保存在范例 device noise profile(造波观察面设备)里. 测试教材还提供观察面文件 SampleProfile.dnp. 用噪波观察面, Neat Image能有效除去图像噪波.

2. 打开范例噪波观察面设备
- 切换到 Device noise profile(噪波观察面设备):
- 在 Device noise profile(噪波观察面设备)框右侧面板上点击 [image] (蓝色磁盘);
- 在 Open device noise profile(打开噪波观察面设备)对话框里, 找到噪波观察面设备的文件夹/目录位置并双击 SampleProfile.dnp;

现在范例噪波过滤器设备是打开的并且Neat Image几乎随时准备去过滤范例图像. 眼下通常将调节过滤设置. 为使第一次操作Neat Image更容易, 我们准备好了一个适合范例图像完善的预置文件存储在范例文件里.

3. 打开范例预置过滤器
- 切换到 Noise filter settings(噪波过滤器设置):
- 在 Filter preset(预置过滤器)框右侧面板上点击 [image] (粉红色磁盘);
- 在 Open filter preset(打开过滤器预置)对话框里, 找到范例过滤器文件夹/目录的位置并双击 SamplePreset.nfp 文件;

现在范例过滤器是打开的并且过滤器已调节了以便处理范例图像.

4. 指定过滤器
- 切换到 Output image(输出图像):
- 在工具栏上点击 [image] 并等到进度指示消失.

处理可能需要一些时间(处理速度要视计算机CPU 而定). 完成之后将显示过滤的图像. 可以切换到input image(输入图像)与当前图像进行比较. 注意噪波 - 特别是天空区域 – 图像细节保存了而噪波已经减少了.

请注意测试教材提供的范例噪波观察面设备和范例预置过滤器仅适合于在特定模式下工作的特定数字摄像机.

详细的过滤处理区域有包括过滤处理, 自定义建造噪波观察面设备在内的详细说明. 还能在Neat Image 网页的范例里发现一些观察面和过滤的范例.


详细的过滤处理

Neat Image可以在同一时间过滤单一或多个图像. 在这部分里, 我们给出一个过滤单一图像处理的详细说明. 见多个图像过滤Queued processing(列队处理)的详细部分.

下面是描述过滤处理图像的设置步骤. 请跟随一个一个的步骤或点按任意一个步骤来阅读特定的详细部分.

第一步. 打开一个输入图像

第二步. 准备一个噪波观察面设备

第三步. 精细调节粗糙的噪波观察面设备 - 任选

第四步. 保存精细调节噪波观察面设备 - 任选

第五步. 调节噪波过滤器设置 - 任选

第六步. 调节锐化设置 - 任选

第七步. 保存过滤设置为预置

第八步. 过滤输入图像

第九步. 保存输出图像


第一步. 打开一个源图像

在过滤工作编辑器里使用 Input image(输入图像):

打开一个输入图像

在工具栏点击 [image] (Open input image…(打开输入图像…)按钮), 或选择 File(文件)|Open input image…(打开输入图像…)菜单选项.

支持的图像格式为BMP, TIFF和JPEG (见详细的Requirements(要求) ).

另外, 使用 Edit(编辑)|Paste(粘贴)菜单选项可以使Windows剪贴板提取另一个应用程序的图像到本程序里. 这个剪贴板图像是24/32-bit RGB格式.

还有, 可以从Windows浏览器里拖拉图像文件到输入图像浏览器中预览.

当输入图像准备就绪, Input image(输入图像)框(在面板的右侧)显示一些关联信息, 例如图像bit 率, 通道和EXIF数据区域(当有效时). 只有EXIF数据区域是对噪波过滤重要的. 因为以后需要参考这些数据.

可以在图像浏览窗口使用鼠标中键或滚动条来定位和滚动图像:
- 滚动鼠标中键放缩图像;
- 按鼠标左键拖拉滚动条来定位图像.

还可以使用鼠标左键同时按键盘 Ctrl 来定位和同时按键盘的 Ctrl-'+', Ctrl-'-' 键来缩放图像.


第二步. 准备一个粗略噪波观察面设备

在过滤工作编辑器里使用 Device noise profile(噪波观察面设备):

要执行过滤, Neat Image需要知道由图像采集设备产生的图像典型的噪波特性(数字摄像机, 扫描仪, 等等.). 通过使用Neat Image构建的 device noise profile (噪波观察面设备)来采集噪波特性. 要获得在确定的某一状态下特殊面, 噪波观察面设备有两种方法—通过测定噪波特性建造一个新的观察面或使用一个以前保存的.

如果一个图像均匀区域包含噪波而无可见的/重要的细节, Neat Image能分析这些区域里其中之一的噪波特性. Neat Image本身不能发现均匀区域(或区域包含无重要的细节), 因此就需要为这个区域指定建造一个噪波观察面来进行分析.

建造一个粗略噪波观察面设备

1. 选择working color space(工作色彩空间)
 在 Device noise profile(噪波观察面设备)框里应用 Working color space(工作色彩空间)列表.

Working color space(工作色彩空间)是过滤算法的内部参数. 一个图像仅在处理时临时改变工作彩色空间(输入和输出图像总是在RGB彩色空间).

我们推荐使用YCrCb JPEG或YCrCb Symmetric彩色空间来分析和处理图像. RGB彩色空间不是最好的识别被噪波遮蔽的图像细节. 使用这个彩色空间很可能将不会产生很好的结果.

正常情况下, 将使用YCrCb JPEG(默认)工作彩色空间为图像精确颜色或者YCrCb Symmetric彩色空间为灰度(半调色)图像. RGB彩色空间还有特殊用途. 例如, 如果打算仅过滤图像的一个特定颜色通道(R, G 或 B)那么需要使用这个空间.

要使用特殊的工作彩色空间需要在空间里建造噪波观察面. 如果改变工作彩色空间Neat Image将要再建造一个噪波观察面.

2. 查找和选择一个均匀图像区域

使用鼠标来选择一个均匀区域(按左键, 拖拉鼠标后再松开按钮).

程序通过分析图像均匀区域的设备来获取噪波特性. 均匀区域(所有通道为较小变化)可以是多云的天空, 晴朗的天空(没有云和鸟), 或者图像任何其它不可看到的可察觉细节的部分,( 除了那些由噪波导致的).

见均匀图像实例.

使用这个选择框只能查找均匀区域和指定它. 它用来挑选灰度(中性)区域较好(但不是必需的). 这个选择将是在最小60x60 像素上. 这是最小尺寸, 而推荐的尺寸是100x100像素或更大. 将会看到选择框根据选择的尺寸改变厚度. 当选择区域时, 这个选择状态在 Rough noise analyzer(粗略噪波分析器)框里将动态指示选择区域是否大的足以建造一个噪波观察面.

可以在工具栏使用 [image] (这个 Show negative of test image(显示负片测试图像)按钮)来暂时使图像进入负片状态. 这样做的情况是更易发现噪波和仅噪波区域.

警告

当有的通道(R,G,B)选择了限制动态范围, 选择状态将显示"signal clipping!(信号终断!)". 如果使用选择的区域创建噪波观察面可能不精确. 请最好避免这种结果.

2.
如果在输入图像里不能发现均匀区域, 可以使用替换测试(参考)图像. 要打开测试图像在工具栏上点击 [image] (这个 Open test image…(打开测试图像…)按钮)(或选择 File(文件)|Open test image…(打开测试图像…)菜单选项). 测试图像将仅在打算建造噪波观察面的 Device noise profile(噪波观察面设备)框里替换输入图像.

还可以从Windows剪贴板上粘贴测试图像或从Windows浏览器里拖拉图像到浏览器里.

3. 使用rough noise analyzer(粗略噪波分析器)分析选定的图像区域

在 Rough noise analyzer (粗略噪波分析器)框里点击 [image] (这个 Rough analyzer(粗略分析)按钮)或者选择 Profile(观察面)|Build using selected area(建造使用选择区域)菜单选项. 仅需要一次操作这个分析就能建造一个粗略噪波观察面.

4. 描述设备名称和设备模式

在 Device noise profile(噪波观察面设备)面板里使用 Device name(设备名称)和 Device mode(设备模式)区域.

在这里, 能指定使用的图像采集设备的模式. 例如, "Nikon CoolPix 950".

还可以描述设备模式. 使用指定参数来获取图像(s). 例如下面:

o     ISO: 225

o     Compression(压缩): 2 bits/pixel(像素)

o     Exposure time(曝光时间): 1/2s

o     Exposure bias(曝光偏移): 0.0 eV

o     White balance(白平衡): Default(默认)

Neat Image能在 Device noise profile(噪波观察面设备)框的 Device name(设备名称)和 Device mode(设备模式)区域里自动写入一些数据. 当EXIF数据区域是有效时在分析图像过程中程序能提取这些数据. 在工具栏上使用 EXIF->Profile(观察面)或选择 Profile(观察面)|Copy EXIF data(复制EXIF数据)菜单选项来进行.

注解

它被推荐来保持指定的这些记录设备, 设备模式和使用的对应噪波观察面设备. 这是很重要的, 因为任何两个噪波特性设备可能非常不同. 每一个设备在不同的模式中可能产生值得注意的不同噪波. 因此, 它总是较好的为不同的设备和设备模式使用个别噪波观察面, 以避免不精确的过滤和人为现象. 存储这个设备名称和设备设置参数可以帮助看清它们.

以后, 改变任何物件时更自动, 例如, 通过比较EXIF标题的输入图像和观察面描述符自动的观察匹配.

注解关于交叉使用噪波观察面

因为噪波观察面是特殊的图像采集设备和模式,在相同(或相似)的情况下从同样的设备里同样观察面的使用能获得处理许多图像. 不过, 它总是能为每个图像建造一个较好的新噪波观察面设备, 因为它可以较好的匹配图像噪波特性.

很可能在不同或稍微不同情况下摄影任何两个图像(设备模式, 摄影条件), 因此, 噪波特性是不同的. 在下面表格里, 大多数描述的是影响设备模式数据(数字摄像机)噪波特性的:

ISO比率 | 50, 100, 200, 400, 等等; 在一台摄像机中 | 更高的ISO比率产生更多图像传感器噪波.
调节锐利 | Low(低), Normal(标准), High(高), 等等; 在一台摄像机中 | 调节摄像机内部的锐利度使噪波更强烈. 要得到好的效果最好使用内部调节.
压缩 | 1:1 (或 未压缩的), 1:5 (或 好), 1:10 (或 标准), 1:20 (或 基本), 等等. 或 2 bits/像素, 4 bits/像素, 等等. 在一台摄像机中 | 强烈的JPEG压缩生产更典型的JPEG人为现象(破坏图像元素包括噪波); 较弱的压缩保留包括图像传感器噪波在内的图像元素. 压缩出好的效果最好使用低数量值.
分辨率 | 1:1 (原始分辨率, 象1600x1200), 1:2 (摄像机缩减, 例如, 800x600), 2:1 (数字缩放, 2x), 等等. | 摄像机内插补(例如数字缩放的缩减和放大)能改变许多噪波特性.
白平衡 | 太阳, 阴天, 白炽, 荧光, 等等; 在一台摄像机中 | 白平衡改变噪波特性(主要是色彩噪波).

如果两个图像是在同样的情况下摄制的(所有设备模式的数据完全相同)那么这两个图像的噪波将非常相似. 如果为这些图像其中一个建造了一个噪波观察面设备, 那可以安全地使用在另一个上.

不过, 如果摄影情况不同, 那两个图像的噪波成分可能及为不同. 在这种情况下, 我们不推荐交叉使用噪波观察面设备.

打开一个预先保存的噪波观察面

在 Device noise profile(噪波观察面设备)框里点击 [image] (这个 Open device noise profile…(打开噪波观察面设备…), 蓝色磁盘)或者选择 Profile(观察面)|Open…(打开…)菜单选项. 在 Device noise profile(打开噪波观察面设备)对话框里, 能指定要打开噪波设备的名称.

可以使用弹出式菜单交替选择预先保存的噪波观察面设备: 在 Device noise profile(噪波观察面设备)框顶部显示的观察面名称上右键单击, 从弹出的菜单里选择观察面. 如果没有弹出菜单, 请点击这个文件夹选项.

见默认工作 来了解下面详细的上述Neat Image噪波观察面关联选项: default color space(默认彩色空间)和 default device noise profile(默认噪波观察面设备).


第三步. 精细调节粗略噪波观察面设备(任选)

注意: 第一次阅读可以跳过这部分.

在过滤工作编辑里使用Device noise profile(噪波观察面设备):

为了更精确的噪波过滤, 它能有效的测量噪波和白度关联之间的级别. 如果噪波与图像白度区域稍微关联, 这种关联将取来评估(例如, 如果强烈的噪波在黑暗区域和衰弱的噪波在光亮区域).

使用噪波观察面均衡器能有效地帮助 [image] Neat Image提高噪波观察面设备的精度. 噪波观察面均衡器用九个滑块来表示每个图像传感器(R, G, B)采集设备采集从图像白度黑到亮的范围.

均衡器滑块相当于在不同白度范围估算噪波的级别, 相对于更早建造的粗略造波观察面. 正值的滑块反映高估算噪波级别并且使Neat Image考虑更多图像存在的噪波; 负值的滑块反映低估算噪波级别并且使Neat Image考虑很少的图像存在的噪波.

可以手动精细调节噪波观察面设备或者自动. 首先提供描述手动处理方法的过程和结果. 再描述自动方法.

手动精细调节粗略噪波观察面设备

1. 使噪波观察面均衡器有效

在 Noise profile equalizer(噪波观察面均衡器)框里通过复选 [image] 复选框.

2. 查找和选择一个均匀图像区域

使用鼠标选择均匀的图像区域.

见均匀图像区域范例.

图像区域大小可以从30x30到300x300像素. 选择框格将根据选择的大小改变厚度. 当选择一个图像区域时, 选择状态在 Noise profile equalizer(噪波观察面均衡器)上下方信息栏里将动态指示包括频率成分(见什么是频率)并且进行分析: high(高), high+mid(高+中), high+mid+low(高+中+低), high+mid+low+very low(高+中+低+很低)频率, 或不能进行分析.

区域大小(像素) | 频率成分分析 | 等级
200x200 - 300x300 | High(高), medium(中), low(低)和very low(很低) | 最好
100x100 - 200x200 | High(高), medium(中)和low(低) | 好
60x60 - 100x100 | High(高)和medium(中) | 一般
30x30 - 60x60 | High(高) | 差

3.
分析将根据选择区域的频率成分进行(高, 中, 低和很低的频率). 当不对一个频率成分进行分析时, 所有这个成分的关联数据是估算的(推断). 那总不是准确的; 因此, 选择大的区域使所有频率成分能得到精确地分析.

警告

当有的通道(R,G,B)选择了限制动态范围, 选择状态将显示"signal clipping!(信号终断!)". 如果精细调节使用选择区域的噪波观察面设备可能不准确. 请最好避免这种结果.

4.
当选择一个图像区域时, 它的白度范围在Noise profile equalizer(噪波观察面均衡器)的Red(红色)面板里以滑块对应位置显示. 还有, 它在均衡器底部色彩指示器里显示.

5. 使用精细调节均衡器来分析选择的图像区域

点击 [image] (这个 Fine-tuning analyzer(精细调节分析器)按钮)或者选择 Profile(观察面)|Fine-tune using selected area(精细调节选择的区域)菜单项目.

分析结果显示在噪波观察面均衡器里. 使用了均匀噪波的区域, 对应滑块将收到'精确的'状态 – 绿底色滑块值, 象 [image]. 如果用一个信号终断的区域来分析噪波特性那对应滑块将收到'不准确的'状态 – 红底色, 象 [image]. 当一个区域意外遇到强列级别的噪波时, 将会应用橙底色, 象 [image].

警告

当分析噪波在对应的白度范围里遇到强列级别的噪波并应用橙底色时, 可能有下列一些原因:

1. 很可能进行的精细调节使用了差的图像区域 (例如, 包括了可见细节);

2. 使用了错误的噪波观察面设备(观察面设备和设备模式不匹配当前图像或者使用了错误的方法建造(粗略)观察面);

3. 图像噪波不常见和包括强烈变化.

橙底色是警告记号. 它不一定表示测量错误. 只是提醒自己在这种情况下如果有必要再建造噪波观察面设备或者选择一个更均匀的区域来精细调节.

红底色是肯定测量错误的记号. 需要复位对用滑块或者撤销最后一次分析(见下面).

6.

7. 如有必要, 复位滑块状态(任选)

点击底色(见更多的底色在下面)下面的滑块复位滑块的状态和数值.

如果滑块是红底色(或任何其它颜色), 可以安全地复位它并分析输入图像的另一部分来设置它的值. 没有必要复位全部均衡器, 因为 是一个错误值.

还有, 可以撤销最后一次分析, 见下面.

8. 如有必要, 撤销最后一次分析(任选)

点击 [image] (这个 Undo(撤销)按钮)或者选择 Profile(观察面)|Undo last fine-tuning analysis(撤消最后一次精细调节分析)菜单项目.

当选择了坏的图像区域导致坏的分析结果时, 取消最后一次精细调节分析很有用.

9. 如有必要, 复位整个均衡器(任选)

点击 [image] (这个 Reset equalizer(复位均衡器)按钮)或者选择 Profile(观察面)|Reset equalizer settings(复位均衡器设置)菜单项目.

10. 使用图像其它均匀区域重复2-6步

要使精细调节的噪波观察面设备更准确需要使用图像别的均匀区域(当然, 多次分析相同区域是没有意义的). 设法挑选均匀区域来覆盖均衡器所有RGB 通道的所有强度范围(即, 获得所有滑块的底色值). 使用底色除红色记号外(用来反映当前选择的强度范围; 象 -40%)来引导精细调节过程. 当操作时还可以使用噪波观察面均衡器下面的色彩指示器来引导. 如果大多数滑块底色为绿色, 可以停止这个操作.

11. 在选项里设置剩余滑块(任选)

如果不是通过了分析, 噪波观察面均衡器滑块有默认值. 可以抛开使用它的默认值或者可以手动调节滑块. 手动调节滑块收到'手动' 状态(黄底色, 象 [image]).

还可以使用 Auto complete(自动完成)功能插入精确的数据来自动调节不可测的滑块. 点击 [image] (这个 Auto fine-tuning analyzer(自动精细调节分析器)按钮)或者选择 Profile(观察面)|Auto complete(自动完成)菜单项目来自动完成精细调节.

参考下面的插图, 它概述了滑块状态记号:

当使用噪波观察面均衡器时, 用色彩指示器来简化精细调节过程. 指示器是以颜色线显示的:
- 噪波观察面均衡器的滑块相当于图像选择区域/像素(use the Shift key for pixel-wise indication);
- 滑动滑块值不同于默认值;
- 滑动滑块值有的(也许)不正确.

参考插图描述各个指示器元素说明:

注解

如果噪波观察面设备是正确地被精细调节了 - 均衡器滑块底色将大部分是绿色, 有时为黄色. 色彩指示器的颜色线所有位置将整个被填满.

12.

自动精细调节粗略噪波观察面设备

1. 使噪波观察面均衡器有效

在 Noise profile equalizer(噪波观察面均衡器)框里复选 [image] 复选框.

2. 使用Auto fine-tuning analyzer(自动精细调节分析器)来分析整个图像

点击 [image] (这个 Auto fine-tuning(自动精细调节)分析器按钮)或者选择 Profile(观察面)|Auto fine-tune(自动精细调节)菜单项目.
通过Neat Image 整个图像将自动被分析并且噪波观察面均衡器的有的滑块将收到'精确的'状态. 其它滑块值将通过 Auto complete(自动完成)功能自动插入替换并且收到'手动状态.
这时可能想检查一下应用自动精细调节后的均衡器值. 在大多数情况下, 这之后不需要手动调节滑块. 如果感觉有必要, 请参考手动部分的说明.
使用鼠标选择一个均匀区域.

要了解Neat Image更详细的 combination of last fine-tuning analyses(结合最后一次精细调节分析)选项见观察面选项.


第四步. 保存精细调节噪波观察面设备(任选)

在过滤工作编辑器里使用 Device noise profile(噪波观察面设备):

保存噪波观察面设备为以后使用

在 Device noise profile(噪波观察面设备)框里使用 [image] (这个 Save device noise profile as…(保存噪波观察面设备为…)按钮, 蓝色磁盘)或者选择 Profile(观察面)|Save as…(另存为…)菜单选项.

在 Save device noise profile as (保存噪波观察面设备为)对话框里能保存噪波观察面设备文件名称. 噪波观察面设备将保存为*.dnp 文件.

保存的噪波观察面包括粗略 – 精细调节的完整信息. 因此, 通过保存噪波观察面, 可以为以后图像处理产生完全相同条件. 还可以同其他用户交换噪波观察面.

另外, 噪波观察面能包含已经用来建造粗略噪波观察面的图像样本. 可以使用程序选项来控制是否内藏进观察面: Save analyzed image area in profile(在观察面里保存分析图像区域).


第五步. 调节噪波过滤器设置

在过滤工作编辑器里使用 Noise filter settings(噪波过滤器设置):

噪波过滤器有许多设置可以调节. 因为这些设置的值是相对于噪波观察面设备特性的, 它们默认值是关闭的, 若通过观察面数据将产生令人满意的结果. 不过, 可以从观察点上发现好的数值并改变设置来产生最好的结果. 最容易的方法是使用预览.

启动预览

· 选择任何图像区域

当一个区域被选择, Neat Image将(如果 auto re-calculate preview(自动再次计算预览)在 选项里是选定的)自动应用过滤选择的图像区域. 还可以用 [image] (这个 Preview(预览)按钮)手动调用重新计算预览, 选择 Filter(过滤器)|Preview(预览)菜单选项, 或者 F5 键.

只要是故意的预览, 就可以在选择的区域中左键单击来暂时切换到原始的并可返复与当前的进行比较.

当调节噪波过滤器设置时使用预览. 见典型过滤结果.

噪波过滤器分为频率和颜色通道成分设置. 各个图像成分有Noise levels(噪波级别)控制器和Noise reduction amounts(噪波衰减数量)控制器.

Noise levels(噪波级别)控制器确定 [image] 经过考虑过的图像噪波元素成分. Noise reduction amounts(噪波衰减数量)控制器确定减少应用到图像里能识别的噪波元素多少.

噪波级别是相对于噪波观察面的. 噪波级别默认是0%(有的噪波级别的默认可能不同), 这意味噪波级别完全由噪波观察面确定, 当级别控制器设置为不同时, 噪波级别估算因此是上升或下降的. 噪波级别能从-100%(那意味无考虑过的图像噪波元素, 并且无噪波衰减应用到对应成份里)到+150%范围(那意味通过噪波观察面确定噪波衰减将是应用到比2.5次还弱的图像元素里).

噪波衰减数量能从0%(检测到没有噪波被移除)到100%范围(检测到所有噪波被移除).

通过默认100%噪波过滤器检测到噪波被移除了(有的从默认的100%噪波衰减数量可能不同). 如果输入图像包括了一些自然噪波, 噪波减少数量可以有明显的影响. 例如, 当过滤图像里的沥青, 沙土或包括细粒的自然噪波的其它还没有特征的东西时, 可以帮助来减少数量下降到40-70%. 我们试验的这些数值通常在保存的图像数据和噪波移除之间提供有效平衡.

调节噪波过滤器设置

· 调节噪波级别(任选)

使用 High(高), Mid(中)和 Low(低); Y, Cr, Cb (R, G, B)噪波级别滑块(Noise filter settings(噪波过滤设置)框).

噪波过滤器能访问输入图像的三个频率成分和三个颜色通道成分. 可以为每个这样的成分修改估算噪波级别.

越高的特别噪波级别, 有越多经过考虑过的图像噪波元素成分对应图像成分. 要小心, 设置噪波级别太低可能导致不完全的过滤: 剩余的噪波和压缩的人为现象可能留在输出图像里. 设置噪波级别太高可能导致移除重要的图像细节.

 通常, 如果噪波观察面设备分析是正确时, 它不需要增加它的噪波级别噪波级别超过50%. 如果一个输入图像在高频率范围包括强烈波动的噪波, 推荐增加它的高频率噪波级别上升置 +20到40%.

如果一个输入图像包括强烈低频率噪波, 可能需要(添加到低到频率成分设置)切换到很低的频率过滤器(Noise filter settings(噪波过滤器设置)框里激活 Very low freq(很低频率)复选框).

如果一个输入图像包括强烈色彩噪波, 推荐增加它的Cr和Cb噪波级别到+30%. 在某些情况下, 增加这些噪波级别到+100%可能更有用.

注解

当人的视觉对色彩变化不是很敏感, 强列过滤图像的Cr和Cb通道引起的失真是注意不到的, 但是能有效的移除色彩噪波.

·

· 调节噪波衰减数量(任选)

使用 High(高), Mid(中)和 Low(低); Y, Cr, Cb (R, G, B)噪波级别滑块(Noise filter settings(噪波过滤设置)框).

可以为图像的所有频率和通道成分改变噪波衰减数. 更高特殊的噪波衰减数, 可以越多的在对应的图像成分里去除检测到的噪波. 当心, 设置噪波衰减数太高可能导致损失好细节和看上去不自然的(光滑溢出, 象 - 塑性)结果. 太低的数量可能不足以去除噪波. 需要平衡这些数量(重要, 噪波衰减数在Y 通道)来获得对视觉最好的结果.

如果一个图像仅有好(高频率)噪波元素, 可以仅利用高频率过滤器并且通过设置它们的数量为0%关闭其它频率过滤器.

打开 Smooth edges(光滑边源)来使图像的边源和线看上去平滑.

Smooth edges
Off | On

·

· 使用预览(任选)

当调节噪波过滤器设置时使用这个预览.

先请改变噪波过滤器参数, 不要忘了再次计算预览. 建议在图像各种不同的部分使用预览来获得过滤结果更好的感触. 我们推荐使用 auto recalculation of preview(自动重新计算预览)(见过滤选项).

如果噪波过滤看上去太强烈/虚弱, 设法为适当的通道减少/增加噪波级别和噪波衰减数量或频率范围. 如果这样得不到帮助, 噪波观察面很可能不足够精确. 回到第三步用好的噪波分析器(精细调节噪波观察面设备)另外分析选定的噪波区域(它应该是没有特性的).

· 使用图像成分面板(任选)

 Image components(图像成分)面板旨在于详细检查图像的频率和通道成分. 检查成分和过滤屏蔽可以帮助更好的调节过滤器设置.

可以通过在工具栏上点击 [image] (这个 Image components panel on/off(图像成分面板开/关)按钮)或者通过菜单选项选择 View(视图)|Image components(图像成分)打开 Image components(图像成分)面板. 面板将会弹出来, 当在现在的主过滤工作编辑器窗口里选择了图像, 这个面板将显示图像成分.

作为各个通道和各频率成分的屏蔽过滤器同样检查单个图像成分(在图像成分面板里使用选择器). 要切换到屏蔽使用 [image] (这个 Show filtration masks(显示过滤屏蔽)按钮). 要在原始和过滤的图像或图像成分之间切换, 在图像面板里的图像上简单地点击.

作为各个通道和各频率成分的屏蔽过滤器同样检查单个图像成分(在 Image components(图像成分)面板里使用选择器).

红色的屏蔽表示标准的(侵蚀) [image] 噪波过滤应用到了区域里(见右侧图片里左上部). 调节噪波过滤器设置(噪波级别)来使红色屏蔽覆盖所有没有的特性区域. 用这些屏蔽任何噪波留下无覆盖.

绿色的屏蔽表示图像区域重要的细节已经检测并且应用了一个特殊类型的噪波过滤. 这个类型的过滤比标准的更灵敏; 它用来保存可见的细节.

蓝色的屏蔽表示区域应用了Sharpening(锐化) (见调节锐化设置).


第六步. 调节锐化设置(任选)

注意: 当第一此次阅读时可以跳过这部分.

在过滤工作编辑器里使用 Noise filter settings(噪波过滤器设置):

能使用锐化过滤器加入不增加图像噪波强度的锐化.

锐化设置的值是相对于噪波观察面和噪波过滤器设置的. 锐化设置值将产生满意的结果(当任何通道成分的锐化被激活时). 不过, 可以用发觉的值改变设置产生要求的锐化级别. 零锐化数将不锐化所有图像. 更高值将应用来指定锐化强度. 使用锐化不同频率成分的控制器来好的, 中等的或大图像细节的锐化. 象使用任何锐化方法, 需要平衡数量来避免多余锐化.

当调节锐化设置时使用这个预览.

调节锐化设置

· [image] 选择要锐化的颜色通道

在 Sharpening settings(锐化设置)框里使用复选框..

如果过滤的是一个RGB彩色空间的图像, 所有色彩通道将被典型地处理. 如果使用YCrCb彩色空间, 通常不需要锐化Cr和Cb通道.

· 设置锐化数量

在 Sharpening settings(锐化设置)框里使用 High(高), Mid(中)和 Low(低)数量滑块.

指定的锐化多少将应用到图像的每个频率成分.

标准锐化设置通过使用许多图形100%为高频率, 0%为中和低频率的编辑装置 (通过使用默认).

· 使用预览(任选)

当调节锐化设置时使用这个预览.

先请改变锐化设置, 不要忘了再次计算预览. 建议在图像各种不同的部分使用预览来获得锐化结果更好的感触.


第七步. 保存过滤器设置为预置(任意)

在过滤工作编辑器里使用Noise filter settings(噪波过滤器设置):

保存过滤器设置为以后使用

在 Filter preset(预置过滤器)框里使用 [image] (这个 Save filter settings as preset…(保存过滤器设置为预置…)按钮, 粉红色磁盘)或者选择 Profile(观察面)|Save filter settings as preset…(保存过滤器设置为预置…)菜单项目.

在 Save filter preset as(保存预置过滤器为)对话框里能指定预置文件名称. 预置过滤器储存为*.nfp 文件.

保存的预置过滤器包括噪波过滤器和锐化设置完整的信息. 因此, 通过保存一定的预置, 可以在以后再现完全相同的设置过滤器. 还可以同其他用户交换预置过滤器. 同时保存噪波观察面和预置过滤器可以用来精确地再现过滤结果.

打开预先保存的噪波观察面

在 Filter preset(预置过滤器)框里点击 [image] (这个 Open filter preset…(打开预置过滤器…)按钮, 粉红色磁盘) 或者选择 Filter(过滤器)|Load filter settings from preset…(从预置里导入过滤器设置…)菜单选项. 在 Open filter preset(打开预置过滤器)对话框里, 能指定名称来打开预置过滤器.

可以使用弹出式菜单交替选择预先保存的预置: 在 Filter preset(预置过滤器)里的名称上右键单击从弹出的菜单里选择预置. 如果没有弹出菜单, 请检查这个文件夹选项.

在建立的Neat Image程序预置子文件夹里有一些预先读入的预置过滤器. 请检查这些预置是否能用来解决典型的任务(预先设置的名称说明这些任务).


第八步. 过滤输入图像

在过滤工作编辑器里使用 Output image(输出图像):

指定过滤到整个图像

1. 选择输出图像类型

从 Filter output(过滤输出)框的列表里选择输出图像类型(24-bit RGB/48-bit RGB; 8-bit/16-bit灰度). 输出图像类型可以不同于输入图像类型. 在这种情况下, 输入图像在处理之前在内部改变成了输出图像类型.

2. 在工具栏上点击 [image] (这个 Apply(添加)按钮)或者选择 Filter(过滤器)|Apply(添加)菜单选项.

处理可能需要几分钟时间(视计算机的CPU和图像大小情况而定). 在这期间, 可以最小化过滤工作编辑器窗口.

注解

Neat Image通常是满负荷应用CPU, 当前情况下, 处理速度是最关键的. 在Celeron 400MHz上, 处理一个2-兆/像素的图像需要大约4分钟 (Neat Image v2.1). 在一台典型配置的计算机中, 处理时间与图像大小成线性关系 (在兆/像素里).

3. 当过滤完成, 可以比较输出和输入图像. 在工具栏上点击 [image] (这个 Compare(比较)按钮)或者仅点击输出图像.

关于过滤关联选项更多的细节: audible indication(声音指示), filter process priority(过滤器处理优先), 等等.见过滤选项.


第九步. 保存输出图像

在过滤工作编辑器里使用 Output image(输出图像):

保存输出图像

在工具栏上点击 [image] (这个 Save output image as...(保存输出图像为…)按钮)或者选择 Image(图像)|Save output image as…(保存输出图像为…)菜单选项.

有效输出的文件格式为: BMP, TIFF, 和JPEG (更详细见要求). 当保存输出图像文件为JPEG格式时, 可以选择压缩质量. 最后使用的压缩质量值总是使用默认值, 除非当保存输出图像文件为JPEG格式时改变了它.

另外, 可以使用Windows剪贴板来输出过滤结果到另一个程序. 为了这个目的使用 Image(图像)|Copy(复制)菜单选项. 图像放在剪贴板上将是24bit RGB帧.

如果过滤结果不满意, 请回到第五步来改变一些过滤设置, 或到第二步或第三步来建造一个新的(或改善存在的)噪波观察面, 更好的匹配噪波来输出图像.


安装插见到图像编辑器

安装Neat Image插件到:

· Adobe Photoshop / Photoshop Elements / ImageReady

从Neat Image 安装文件夹里复制 NeatImage.8bf (典型地, C:\Program Files\Neat Image 2.5 Pro Plus\)代替Photoshop / Photoshop Elements / ImageReady 文件夹里的 Plugins 或 Plug-ins. 启动程序, 将发现Neat Image插件在 Filter(过滤器)菜单下面的 ABSoft子菜单里.

· Jasc Paint Shop Pro

打开 File(文件)菜单, 选择 Preferences(优先选择) | File locations(文件位置)(PSP7+)或 or Preferences(优先选择) | Plug-in Filters(插件过滤器)(PSP4-6)并且选择 Neat Image安装文件夹. 点按OK, Neat Image插件将出现在 Effects(效果)菜单 Plug-in Filters(插件过滤器)里.


Using the plug-in to process images

Neat Image plug-in can be invoked from an image editor to process the selected part of one layer or one channel of the current image. This subsection explains key steps of applying Neat Image plug-in. Since these steps are very similar to the filtration process of the Neat Image standalone version, the sequence of steps is described on the basis of the Filtration process details section.

Step I. Invoke the plug-in from the image editor

Select a layer or a channel that should be processed. In this layer/channel, select an area to be filtered (all layer/channel will be filtered if no area is selected).

Invoke the Neat Image plug-in using the standard way of invoking filter plug-ins from your image editor:

  • Adobe Photoshop / Photoshop Elements / ImageReady

Select the menu item Filter | ABSoft | Neat Image…

  • Jasc Paint Shop Pro

Select the menu item Effects | Plug-in Filters | ABSoft | Neat Image…

Step II. Prepare a rough device noise profile

Preparing a rough device noise profile is done in the same way as with the standalone version of Neat Image. Please see Step II. Prepare a rough device noise profile

Step III. Fine-tune the rough device noise profile (optional)

Fine-tuning the rough device noise profile is done in the same way as with the standalone version of Neat Image. Please see Step III. Fine-tune the rough device noise profile (optional)

Step IV. Save the fine-tuned device noise profile (optional)

This is done in the same way as with the standalone version of Neat Image. Please see Step IV. Save the fine-tuned device noise profile (optional)

Additionally, Neat Image plug-in will automatically remember the device noise profile prepared at this point. This will allow re-applying the plug-in with the same device noise profile without repeating the steps II-IV.

Step V. Adjust noise filter settings

This is done in the same way as with the standalone version of Neat Image. Please see Step V. Adjust noise filter settings

Step VI. Adjust sharpening settings (optional)

This is done in the same way as with the standalone version of Neat Image. Please see Step VI. Adjust sharpening settings (optional)

Step VII. Save the filter settings into a preset (optional)

This is done in the same way as with the standalone version of Neat Image. Please see Step VII. Save the filter settings into a preset (optional)

Additionally, Neat Image plug-in will automatically remember the filter settings selected at this point. This will allow re-applying the filter with the same filter settings without repeating the steps V-VII.

Step VIII. Apply filter

Use the Noise filter settings tab in the plug-in:

To apply filter to the image

Click [image] (the Apply button) on the toolbar or select the Filter|Apply menu item.
The plug-in window will be closed and filtration starts. Processing may take a few minutes (depending on the speed of your computer's CPU and size of (the selected part of) the image). During this time, the image editor will display filtration progress.


队列处理

Neat Image可以用来自动过滤多个图像. 使用这种方法可以创建一些图像过滤工作, 将它们放置进工作列队里并让这些列队工作一个接一个进行.

当存在的工作为后台处理时, 还可以创建新的工作. 在单一(批量)里创建许多工作用相同的过滤参数来过滤许多图像. 还可以在任何时间改变任何工作的过滤参数.

在这里我们将详细说明如何使用软件所有这些能力.

当阅读读部分时, 请一定确定在Neat Image选项里 Auto create new job at startup(在启动时自动创建新的工作)设置(使用 View(视图)|Options…(选项…)菜单选项)非复选. 如果它被选中, 在启动时过滤工作编辑器将代替过滤列队窗口出现. 选中这个选项通过默认来使程序初始工作更容易.

· 过滤列队窗口

· 创建新的图像过滤

· 编辑图像过滤工作

· 移除图像过滤工作

· 列队和保持图像过滤工作

· 启动和停止过滤列队

· 保存输出图像


过滤列队窗口

当启动Neat Image, 过滤列队窗口会打开(需要在Neat Image选项里非复选 Auto create new job at startup(在启动时自动创建新的工作)设置). 这个窗口包括过滤列对它本身(在框中心), 用工具来创建, 编辑, 删除, 启动和停止工作(在工具栏上), 并且右侧面板有关于总体和单一选定图像过滤工作的详细的信息.


创建新的图像过滤工作

Neat Image是一幅一幅处理图像并使用特殊的设置来为每个图像应用过滤. 单一的过滤工作包括一个图像和一个自定义过滤器设置. 可以创建和配置一个或多个过滤工作并让Neat Image进行所有处理.

创建新的图像过滤工作

在工具栏上点击 [image] (这个 Create new image filtration job(创建新的过滤工具)按钮)或者选择 Job(工作)|New…(新建)菜单选项.

新的过滤工作将创建. 过滤工作编辑器将自动打开并且将能象在详细的过滤处理部分的跟随步骤一样选择输入图像, 噪波观察面设备和过滤器设置.

当处理工作就绪后, 如果不想在过滤工作编辑器里处理, 可以在队列处理.

当输入图像, 噪波观察面和过滤设置就绪后, 可以在 Queued processing(列队处理)框中使用 Queue(列队)这个控制器新建列队过滤处理工作.
单击 [image] 将迫使工作转到下面的列队里, 当转到列队后Neat Image就可以进行处理了.

还可以选择 Auto save output image(自动保存输出图像)并使用这个[…]按钮指定 Output image file name for auto save(输出图像为自动名称保存). 当选择了自动保存, Neat Image 将自动保存输出图像到指定的文件里, 在过滤列队里这个工作完成的很快.

当选中 Auto save output image(自动保存输出图像), 然后完成了工作并且输出图像成功地保存了, 可以另外从列队里选择 auto delete completed job(自动删除完成工作).

Neat Image会询问自动保存图像的放置位置. 还会询问特殊图像保存属性, 例如, JPEG品质. 提供最后使用的品质为默认值.

如果不想工作处理列队进行, 只需按 Esc 按钮或选择 File(文件)|Put this job to queue(放置这个工作到列队)菜单选项. 工作将放置在列队里直到手动处理它.

立刻创建多个图像过滤工作

· 在工具栏里点击 [image] (这个 Create many filtration jobs at once(立刻创建多个过滤工作)按钮)或者选择 File(文件)|Batch…(批量…)菜单选项.
Batch(比量)窗口将会出现, 允许选择处理的一些图像文件. 还有, 将能选择一个噪波观察面设备和一个预置过滤器用来过滤所有选择的图像.

· [image] 使用 [image] 添加新的图像文件到列表中.

· 使用 [image] (蓝色磁盘)或弹出菜单选择一个噪波观察面设备来过滤列表中的所有图像.

· 使用 [image] (粉红色磁盘)或弹出菜单选择一个预置过滤器来过滤列表中的所有图像.

· 在下拉列表里指定输出文件类型(8/24bits或16/48 bits).

· 复选希望的'自动'-操作将添加到列队的所有工作中: auto start filtration(自动启动过滤), auto save output images(自动保存输出图像), auto delete completed jobs(自动删除完成工作).

· 选择输出图像格式: TIFF, JPEG或BMP.

· 点击 [image] 添加新的图像过滤工作到列队.

随即Neat Image会询问将自动保存的输出图像放置在磁盘的位置. 还会询问特殊保存的特性, 例如, JPEG品质级别.

之后, 一些新的图像过滤工作将在列队里创建. 如果自动启动已经选中, 这些工作将立即由处理.

通过拖拉创建一个或多个新的图像过滤工作

可以从Windows管理器里拖拉一些图像文件到列队窗口. Neat Image将自动为每个拖拉的文件创建新的过滤工作 - 使用在选项中默认的指定.


编辑图像过滤工作

任何时候可以在列队里改变编辑需要的一些过滤参数. 这适用于所有在列队里的除了正在处理的一个. 需要点按hold(保持)(使用 [image], 见下面细节)才能编辑它.

编辑正在过滤工作的图像

在列对里选择一个工作并点击 [image] (这个 Edit selected filtration job(编辑选择过滤工作)按钮)或者选择 Job(工作)|Edit…(编辑…)菜单选项.

过滤工作编辑器将打开选择的工作, 并且将可以修改它的细节包括input image(输入图像), device noise profile(噪波观察面设备)和and filter settings(过滤器设置). 所有这些改变根据 详细的过滤处理 部分进行.

当处理工作就绪后, 可以在 Queued processing(列队处理)框里使用Queue(列队)控制器返回到列队里.


移除图像过滤工作

移除存在的图像过滤工作(s)

在列队里选择一个或多个想要移除的过滤工作.

点击 [image] (这个 Delete selected filtration job(删除选择的过滤工作)按钮)或选择 Job(工作)|Delete(删除)菜单选项.


列队和保持图像过滤工作

图像过滤工作处理在列队里是准备好的(例如, 输入图像和噪波过滤器是选中的)除非特意用了Hold(保持). 使用了Hold(保持)工作将不进行处理直到Queue(列队).

列队存在的图像过滤工作(s)

在列表里选择一个或多个想要处理的过滤工作.

点击 [image] (这个 Queue selected job(选择列队工作)按钮)或选择 Job(工作)|Queue(列队)菜单选项.

当它们回过来时选择的工作(s)将收到启动'列队'并且将进行处理.

保持存在的图像过滤工作(s)

在列队里选择想要保持的一个或多个过滤列队.

点击 [image] (这个 Put selected job on hold(保持选择的工作)按钮)或者选择 Job(工作)|Hold(保持)菜单选项.

选择的工作(s)将收到启动 '在保持 ' 并且将不进行处理.


启动和停止过滤列队

有时可能需要完全停止(然后再次启动)过滤列队. 这能在 Filtration queue(过滤列队)框里进行控制.

停止过滤列队

在过滤列队里点击 [image] 停止处理工作.

启动过滤列队

在过滤列队里点击 [image] 启动处理工作.


保存输出图像

当一个工作在过滤列队里进行时, 很可能想保存这个结果. 这可以在过滤工作编辑器(可以使用 Edit(编辑)按钮打开它)或直接从过滤列队里进行.

为过滤工作保存一个输出图像

点击 [image] (这个保存输出图像按钮).

注意使用这个按钮能保存比一个工作更多的输出图像. 选择一些完成工作并点击这个按钮来一次保存一些输出图像.


General(通用)选项

Show splash screen at startup(在启动时显示程序标签)

这个选项控制在程序起动时显示程序标签(黄色的花图片).

Auto create new job at startup(在起动时自动创建新的工作)

当选中这个选项, 起动后出现Filtration job editor(过滤工作编辑器)(代替Filtration queue(过滤列队)窗口), 如果只想处理单个图像而不去列队窗口时有用.

选中这个选项通过默认使程序初始工作更易.

如果需要使用过滤列队做许多工作, 我们劝告你切换这个选项为关.

Show hints over interface controls(在界面上显示控制提示)

这个选项允许切换开/关提示. 当鼠标指针放在程序控制器上时显示提示.

Double buffer image viewers(双倍缓冲图像浏览器)

这个选项控制图像浏览器缓冲装置. 双倍缓冲图像浏览器提供在不损失渲染速度的情况下平滑显示渲染. 禁止这个选项使在缓慢的机器上操作最好.

Allow overwriting existing image files(允许重写当前文件)

选择个选项, 当输出图像通过程序自动保存, 允许Neat Image重写存在的图像文件(在列队处理时).


Job defaults(默认工作)

Default color space(默认彩色空间)

当一个新的图像过滤工作被创建时, 选择这个工作彩色空间用于默认设置(如果没有选择默认观察面; 见下面的默认噪波观察面设备). 如有必要, 以后可以总是改变工作彩色空间; 这个选项只提供一个默认选择.

这个工作彩色空间是一个彩色空间由Neat Image用来分析和处理图像的. 当前, 有三个工作色彩空间可以使用: RGB, YCrCb JPEG, 和YCrCb Symmetric. 为了大多数图像, 我们推荐使用YCrCb JPEG色彩图像和YCrCb Symmetric灰度(半调) 图像.

注意: 工作彩色空间不影响或改变任何颜色轮廓(ICC 轮廓)嵌入到图像里.

Default output bitdepth(默认输出bit深度)

这个选项控制由过滤处理的图像默认的bit深度. 例如, 如果一个图像输入是8/24 bits, 而输出的bit深度选择了bits, 那输出将转换为16/48 bits, 用过滤器处理后的输出图像将是16/48 bits. 如果选择了 match input(匹配输入), 输出图像bit深度将匹配输出图像bit深度.

Default device noise profile(默认噪波观察面设备)

当创建一个新的过滤工作时噪波观察面设备文件是通过Neat Image自动打开的. 使用在下面的文件浏览器([…] 按钮)可得到空间来指定噪波观察面的名称和位置.

如果时常使用同样的观察面可能要用到这个选项. 任何有效的噪波观察面都可以设为默认.

Default filter preset(默认预置过滤)

当一个新的图像过滤工作创建时过滤设置自动导入默认的预置过滤器. 使用在下面的文件浏览器([…] 按钮)可得到空间来指定预置文件的名称和位置.

如果时常使用同样的预置可能要用到这个选项. 任何有效的预置过滤器都可以设为默认.

Auto save output image(自动保存输出图像)

在框里复选这个 auto save output image(自动保存输出图像)选项将过滤工作编辑器和批量窗口设为默认自动保存输出图像.

Auto delete completed job(自动删除完成工作)

在框里复选这个 auto delete completed job(自动删除完成工作)选项选项将过滤工作编辑器和批量窗口设为默认自动删除完成工作.

Output file name suffix(输出文件名称后缀)

通过默认选择后缀添加到输出图像文件名称里.


Profiling options(观察面选项)

结合最后精细调节分析

这是一种在噪波观察面均衡器里结合多重精细调节分析的方法(关联相同白度范围).

在命令测量图像关联的噪波和白度之间(通常是进行第三步的过滤步骤精细调节噪波观察面设备, 见第三步.精细调节粗略噪波观察面设备)它必需分析图像许多均匀区域. 每单个分析确定一些关联的狭窄区域白度值. 噪波观察面均衡器滑块反映关联的相当于白度每个RGB 颜色通道特殊区域数目.

最初, 所有滑块的位置是默认的. 分析将改变它们和谐的位置反映噪波特性.

可能在相同的白度范围内获得的不同分析将影响相同的滑块. 在这种情况下, 滑块状态的确定通过 Combination of last fine-tuning analyses(结合最后一次精细调节分析)选项:

· Take the maximum value(获得最大值) (推荐)
- 均衡器设置滑块值最大为最后两次分析值(侵蚀过滤, 最大噪波移除);

· Take the minimum value(获得最小值)
- 均衡器设置滑块值最小为最后两次分析值(侵蚀过滤, 最小噪波移除);

· Take the average value(获得平均值)
- 均衡器设置滑块值平均为最后两次分析值;

· Take the last value(获得最后值)
- 均衡器设置滑块RGB值为当前分析值.

Save analyzed image area in profile (*.dnp file)( 保存观察面分析的图像区域 -*.dnp文件 )

选中这个选项使Neat Image保存分析的噪波观察面设备图像区域(*.dnp 文件). *.dnp 文件大小将增加但也可以提高软件将来版本的兼容性(Neat Image将能再建造使用保存的图像区域).


Filtration options(过滤选项)

Audible indication(可闻指示)

Neat Image有简单的音响信号系统.

复选 when filtration jobs are processed(当过滤工作处理时)来启动/禁止正在过滤处理的间歇声音. 这可以帮助监视程序处理工作.

Use when all filtration jobs are done(当所有过滤工作在进行时使用)是用来指示启动/禁止过滤工作的单个声音.

Filtration job editor(过滤工作编辑器)

Auto minimize(自动最小化)是用来自动最小化正在过滤的过滤工作编辑器窗口. 有两个目的; 一是加快处理和保存内存, 二是当它工作时没有获得编辑器办法.

Auto restore(自动恢复)是用来在过滤结束后自动恢复过滤工作编辑器窗口.

Filtration job editor(过滤列队窗口)

Auto restore(自动恢复)当所有过滤工作在进行时自动恢复过滤列队窗口.

Filter process priority(过滤处理优先)

在多任务环境中使用这个选项来调节过滤处理运行优先权:

· Idle(空闲) — 最低优先权; 在需要时过滤让位给其它程序.

· Below(低) — 优先权在标准以下; 提供所有程序平滑性能. 这可能减慢Neat Image一点, 但能让其它程序工作正常, 尤其是速度慢的计算机.

· Normal(正常) — 正常优先权; 过滤可能稍微减慢其它程序.

Auto recalculate preview(自动重算预览)

这个选项在过滤工作编辑器里自动启动/禁止重算预览. 当激活, 每次选择一个新的图像区域或改变过滤器参数时自动调用重算.

...every N second(s)(每N秒)

在改变过滤器参数和重算自动预览之间的延迟时间.

注意: 只有当 Noise filter settings(噪波过滤器设置)使用时才调用自动预览.


Folder options(文件夹选项)

Use independent open/save folders/directories(应用独立打开/保存文件夹/路径)

这个选项为打开和保存文件允许使用两个独立的文件夹(路径). 如果选中这个选项Neat Image将记忆两个文件夹, 否则, 打开和保存文件仅用一个文件夹.

Use independent folders/directories for images/profiles/presets(为图象/观察面/预置应用独立文件夹)

这个选项为工作图像, 观察面设备和过滤器预置允许使用三个独立的文件夹(路径). 如果选中这个选项Neat Image将记忆三个文件夹, 否则, 图像, 观察面和预置仅用一个文件夹.

Temporary folder/directory(临时文件夹/目录)

选择Neat Image 将用来储存临时文件的文件夹/目录.

Profile folder/directory(观察面文件夹/目录)

Neat Image寻找噪波观察面要选择的文件夹. 这是所有的有噪波观察面设备的文件夹(子)的最上面文件夹. 这样, 在Neat Image的 Filtration job editor(过滤工作编辑器)Device noise profile(噪波观察面设备)面板里弹出的菜单中将能显示所有观察面(指定储存的所有子文件夹).

Preset folder/directory(预置文件夹/目录)

Neat Image寻找预置过滤器要选择的文件夹. 这是所有的有预置过滤器的文件夹(子)的最上面文件夹. 这样, 在Neat Image的 Filtration job editor(过滤工作编辑器)Noise filter settings(噪波过滤器设置)面板里弹出的菜单中将能显示所有预置.
通过默认, 预置子文件夹安装在Neat Image使用的文件夹里.


建造一个图像噪波观察面设备(实例)

见下面实例图像是建造噪波观察面设备选择的好和坏的图像区域. 在这里, 突出的绿色图像区域适合于建造噪波观察面; 那些突出的红色区域不适合使用. 注意适合于建造噪波观察面设备的图像区域最小要比60x60像素大(最好超过100x100像素).

关于图像区域选择的附加注解显示在下面.

当在所有频率范围包括它们不可见细节时, 这些图像区域是 can be used(能用来)建造噪波观察面设备的:

– 好, 因为这个区域包括无重大细节

– 好, 无重大细节 (这是另外一个图像的区域)

下列图像区域 should not be used(不能用来)建造噪波观察面设备, 因为它们包括了可见细节:

– 坏, 因为这个区域包括了一个细节: 壁角– 连接墙壁和天花板

– 不可接受, 因为这个区域包括了许多细节

– 坏, 因为这个区域包括了某一细节: 云(这是另外一个图像的区域)

见建造噪波观察面设备 更多实例在Neat Image网页.


精细调节一个噪波观察面的图像

在这部分, 可以查找图像区域实例, 在噪波观察面均衡器里精细调节分析:

大尺寸区域

在图像区域大于100x100像素时, 取高, 中和低频率估算.

在不同情况下建造一个噪波观察面设备, 实例在本质上是相同的. 见建造一个噪波观察面设备实例.

中尺寸区域

在图像区域比60x60像素大但比100x100像素小时, 取高和中频率估算:

– 好, 因为这个区域包括无重大的细节

– 坏, 因为这个区域有中频率细节(一垂直划痕)

– 不可接受, 因为这个区域有许多中频率细节(水平划痕)

小尺寸区域

在图像区域比30x30像素大但比60x60像素小时, 只取高频率估算:

– 好, 虽然这个区别对待包括低频率细节, 但它们可忽略不计因为是小区域

– 坏, 因为这个区别区域包括高频率细节(一垂直滑痕)

– 不可接受, 因为这个区域包括不同细节

见精细调节噪波观察面设备的更多实例在Neat Image网页.


过滤结果

这里是一些Neat Image 的操作实例.

Input(输入) | Output(输出)
这一小部分数字照片取自于Nikon CoolPix 950数字摄像机. 原图像包含了容易看见的噪波. 这种情况的噪波是来源是摄像机的图像传感器(CCD)置入了ISO模式.

Input(输入) | Output(输出)
这张图像是取自于Kodak DC 210数字摄像机. 有高浓重的图像传感器(CCD)ISO噪波, 这张图像的降级是由于JPEG压缩引起的. 即使Neat Image会设法竭力洁净这样的图像, 但还是要避免使用强烈的JPEG压缩!

去Neat Image的网页上了解更多的过滤实例.


过滤的有关问题

Q 为什么过滤的图像有一些晶状的人为痕迹?

A 过滤的图像有晶状的人为痕迹(这是由于JPEG压缩产生的). 可以在噪波过滤器里通过增加高频率设置值来消除这种痕迹.

注意: 出现许多残留的人为现象通常是使用了建造不合适的噪波观察面设备或者是建造了另一个设备或设备模式的结果.

Q 为什么过滤的图像象'塑性'?

A 原因是应用过滤太过分了. 应该让Neat Image保留一些噪波使之看上去比较自然. 调节噪波衰减数量; 参考衰减Y通道数到 50-70%.

Q 什么是频率?

A 频率是在Neat Image里用来指示图像元素大小的专用术语(重要细节和噪波).

高频率相当于图像的元素尺寸极小. 中频率相当于图像的元素尺寸中等. 低频率相当于图像的元素尺寸(相对)很大.

要参见噪波样本的不同频率在过滤工作编辑器的 Noise filter settings(噪波过滤器设置)里.

Q 过滤处理慢, 这是正常的吗?

A 这是正常的, 因为过滤算法非常复杂. 我们正在进行优化工作将会提供更好的性能.

Q Is the input image automatically changed according to the profile that is being opened?

A The input image is NEVER changed. Neat Image always creates a new output image, which contains the filtration results. The output image can then be saved to any file.

Q 如何只过滤颜色噪波(不是白度噪拨)?

A 当使用YcrCb空间时, 设置Y通道噪波白度衰减值(Noise filter settings(噪波过滤器设置)框)为0%. 这样将关闭过滤白度(亮度)通道 Y.

Q 什么是YCrCb?

A 广泛用于电视, 图像压缩系列数字像图色彩空间的YCrCb 名称(例如, 在空间里存储的JPEG压缩图像), 等等.

在'YCrCb'里, 'Y' 相当于亮度通道, 'Cr' – 到Cr色度通道覆盖红到蓝 – 绿色范围, 'Cb' – 到Cb色度通道覆盖蓝到黄色范围. 因为这些空间能轻易分离亮度和色度信息, 它适合于噪波过滤的需要.

Q Neat Image Is processing via Neat Image best done before or after any other processing (i.e. tonal/color correction)?

A Such operations as tonal/color correction are quite conservative from the standpoint of noise, i.e., they do not significantly change the noise characteristics of the image. Therefore, filtering before or after makes little difference - as long as the device noise profile is built and applied at the same stage of image processing. For example, don't use a device noise profile built with an unprocessed image to filter a processed image.

Some digital cameras apply some color correction internally. Other cameras allow access to unprocessed RAW data. Neat Image is a generic filter, which can be applied in both cases. The only requirement is to use matching profiles.

On the other hand, image sharpening applied to a noisy image makes it much more noisy. It is best to apply Neat Image filtration before sharpening (including internal camera sharpening). However, the sharpening and noise filters of Neat Image can be used together because the sharpening is applied AFTER noise filtration.


过滤阴暗区域

在有些情况下, 它能较好地只过滤图像的阴暗区域而不会影响明亮区域. 使用这个操作可以在Neat Image通过使用噪波观察面均衡器来限制或停止过滤图像明亮区域.

噪波观察面均衡器滑块相当于白度特殊范围的(每个颜色通道单独的)RGB彩色空间. 每个滑块变化的位置(精细调节)为噪波观察面对应于白度范围的参数. The lower a slider, the less filtration will eventually be applied to image elements that belong to the corresponding range of brightness.

因此, 要只过滤阴暗可以手动移动所有'明亮' 的滑块往下(参考噪波观察面均衡器底部的渐变). 例如, 在三个RGB通道里往下移动所有滑块.

使用这种方法能有效地防止过滤图像明亮区域.


二次过滤

有的图像包括噪波和纯净这两个区域并且它可能只较好的过滤了噪波区域. 这可以在图像编辑器里通过结合两个图像 - 原始的和过滤的手动操作. 例如, 可以跟随下列步骤:

1. 在Neat Image 里过滤输入图像(噪波和纯净这两个区域)并保存输出图像为一个新文件;

2. 在图像编辑器里打开这个新文件;

3. 放置过滤图像在原始图像上面的新层里;

4. 调节新层的透明度使噪波区域显得好些;

5. 选择并删除过滤新层的不必要或极端的区域(可能要使用擦除器工具来调整透明度和形状).


加快处理

如果不处理一个(或多个)图像成分可以获得更好的过滤速度. 要禁止处理一个频率成分设置这个成分的噪波衰减数量和锐化数量到0%. 要禁止处理一个色彩通道的成分设置噪波衰减数量到0%并禁止锐化这个通道.


已知故障

我们设法尽可能地防止故障远离Neat Image. 请告知在使用Neat Image时遇到的故障或问题(甚至在下面已经描述的). 为了方便, 在Neat Image 网页里有我们的在线故障报告表. 你的反馈将极大的帮助我们改善软件并提供更好的图像工具给你. 预先谢谢你!

已知故障和问题列表

· 迄今为止没有


计划

Neat Image当前版本是我们进行研究噪波过滤的结果. 有关过滤算法我们正在继续工作, 以便提高噪波衰减的品质和速度. 另外, 以后我们计划引进新的功能, 比如:

· Mac版本

· 去除强像素

请让我们知道如果你有能使程序更好想法. 在Neat Image的信息板参加讨论, 表达你的意见, 提出建议, 并且询问问题. 记住, 更多人要求的特征更可能使它完善.


联系

我们真诚地感谢你对Neat Image的建议. 请让我们知道你对程序看法. 随便问关于Neat Image 的问题. 分享你的意见或接收对Neat Image 的支持, 使用下列方法:

E-mails

info@neatimage.com — 常规查询

support@neatimage.com — 关于任何Neat Image 使用的查询

sales@neatimage.com — 关于任何购买Neat Image的查询

信息版

在Neat Image社区论坛注册, 并参加使用和开发Neat Image 的讨论. 论坛上覆盖了这样的主题:

· 通告新的和修改的软件版本;

· 调查关于Neat Image的使用;

· 使用Neat Image的范例和注解与建议;

· 用户反馈: 建议新的特征和新的改进;

· 投票: 什么的OS, CPU, 使用的摄像机类型和NI;

· 联系和常规注解.

网页

主位置


答谢

Neat Image利用的是英特尔JPEG库.

Neat Image基本能打开TIFF 库.

对所有提出改进Neat Image 建议的用户表示感谢.

对所有帮助我们发现Neat Image错误的人表示感谢.

对加快有完善Neat Image言论和行动的用户表示感谢.

没有你们所有的人图像将不会整洁!

Neat Image 组, ABSoft